summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 09:48:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 12:50:08 +0200
commitc954e8d7991bf307c46c87c4f21c5970dcc27bf3 (patch)
tree02d4cff16d8245dcddea8e2c56d506b6398d3859 /dev-ros/image_cb_detector
parentdev-ros/calibration_setup_helper: Bump to 0.10.15. (diff)
downloadgentoo-c954e8d7991bf307c46c87c4f21c5970dcc27bf3.tar.gz
gentoo-c954e8d7991bf307c46c87c4f21c5970dcc27bf3.tar.bz2
gentoo-c954e8d7991bf307c46c87c4f21c5970dcc27bf3.zip
dev-ros/image_cb_detector: Bump to 0.10.15.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/Manifest1
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/image_cb_detector/Manifest b/dev-ros/image_cb_detector/Manifest
index 0c2018f9b46d..7d01d5458acf 100644
--- a/dev-ros/image_cb_detector/Manifest
+++ b/dev-ros/image_cb_detector/Manifest
@@ -1 +1,2 @@
DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+DIST calibration-0.10.15.tar.gz 115940 BLAKE2B 43c8564ad8f15894d04571fbb3c6bc2059a5d232de3fb6225b715b078a11fef2e19283e3f0587ed47f2d52784ade22bebdf4680f6b30c585da2fbbfa1c45b0a5 SHA512 06ffc9ae6872b914eb6954996d165e2aa65d786756896a21be1ab3b5c20f1df3340e2fdf9804bc3cd78089f5b2e05eaed2a4376e70e98ccaaa8a88d95c3f4894
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild
new file mode 100644
index 000000000000..505371176272
--- /dev/null
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from ROS images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/cv_bridge[${PYTHON_SINGLE_USEDEP}]
+ media-libs/opencv:=
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" "${FILESDIR}/boost170.patch" )