summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 10:57:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 11:44:12 +0200
commit0eb513aab4b0670e06707d2b2b57ace45c187d4c (patch)
tree7ab73a8fa3617d559f566913bb8a5803a036753d /dev-ros/image_geometry/image_geometry-9999.ebuild
parentdev-ros/cv_bridge: Initial import. Ebuild by me. (diff)
downloadgentoo-0eb513aab4b0670e06707d2b2b57ace45c187d4c.tar.gz
gentoo-0eb513aab4b0670e06707d2b2b57ace45c187d4c.tar.bz2
gentoo-0eb513aab4b0670e06707d2b2b57ace45c187d4c.zip
dev-ros/image_geometry: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/image_geometry/image_geometry-9999.ebuild')
-rw-r--r--dev-ros/image_geometry/image_geometry-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/image_geometry/image_geometry-9999.ebuild b/dev-ros/image_geometry/image_geometry-9999.ebuild
new file mode 100644
index 000000000000..82066472ce06
--- /dev/null
+++ b/dev-ros/image_geometry/image_geometry-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ and Python libraries for interpreting images geometrically"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-libs/opencv
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"