summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 19:15:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:35 +0100
commitdad7cd688e634083c6a40eb60961777479a6698f (patch)
tree9ab03bf065cae2b7475d07906fc228af3683c56c /dev-ros/image_proc/image_proc-1.12.22-r1.ebuild
parentdev-ros/image_proc: Remove old (diff)
downloadgentoo-dad7cd688e634083c6a40eb60961777479a6698f.tar.gz
gentoo-dad7cd688e634083c6a40eb60961777479a6698f.tar.bz2
gentoo-dad7cd688e634083c6a40eb60961777479a6698f.zip
dev-ros/image_proc: add missing console bridge dep
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/image_proc/image_proc-1.12.22-r1.ebuild')
-rw-r--r--dev-ros/image_proc/image_proc-1.12.22-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_proc/image_proc-1.12.22-r1.ebuild b/dev-ros/image_proc/image_proc-1.12.22-r1.ebuild
new file mode 100644
index 000000000000..bd66af15e302
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.22-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv:=
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"