summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-23 13:22:18 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-23 13:28:12 +0100
commit0d681298f8a3ca967597555e3df315160a3303d5 (patch)
tree3d97ea60611aafa9c6dfcafe656c01f49d3d11d1 /dev-ros/image_proc
parentdev-ros/image_proc: remove old (diff)
downloadgentoo-0d681298f8a3ca967597555e3df315160a3303d5.tar.gz
gentoo-0d681298f8a3ca967597555e3df315160a3303d5.tar.bz2
gentoo-0d681298f8a3ca967597555e3df315160a3303d5.zip
dev-ros/image_proc: Backport upstream patch to build with gcc6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/image_proc')
-rw-r--r--dev-ros/image_proc/files/gcc6.patch32
-rw-r--r--dev-ros/image_proc/image_proc-1.12.19.ebuild3
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ros/image_proc/files/gcc6.patch b/dev-ros/image_proc/files/gcc6.patch
new file mode 100644
index 000000000000..88a8d9b85756
--- /dev/null
+++ b/dev-ros/image_proc/files/gcc6.patch
@@ -0,0 +1,32 @@
+commit 6c2d65452bd5fe62723988a1a570789921900d59
+Author: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+Date: Fri Sep 30 15:39:47 2016 +0200
+
+ address gcc6 build error
+
+ With gcc6, compiling fails with `stdlib.h: No such file or directory`,
+ as including '-isystem /usr/include' breaks with gcc6, cf.,
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129.
+
+ This commit addresses this issue for this package in the same way
+ it was addressed in various other ROS packages. A list of related
+ commits and pull requests is at:
+
+ https://github.com/ros/rosdistro/issues/12783
+
+ Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>
+
+diff --git a/image_proc/CMakeLists.txt b/image_proc/CMakeLists.txt
+index a13371f..34905f0 100755
+--- a/image_proc/CMakeLists.txt
++++ b/image_proc/CMakeLists.txt
+@@ -17,8 +17,7 @@ catkin_package(
+ LIBRARIES ${PROJECT_NAME}
+ )
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+-include_directories(include)
++include_directories(include ${catkin_INCLUDE_DIRS} ${OpenCV_INCLUDE_DIRS})
+
+ # Nodelet library
+ add_library(${PROJECT_NAME} src/libimage_proc/processor.cpp
diff --git a/dev-ros/image_proc/image_proc-1.12.19.ebuild b/dev-ros/image_proc/image_proc-1.12.19.ebuild
index 08dd3217ec2f..72fc4380ed71 100644
--- a/dev-ros/image_proc/image_proc-1.12.19.ebuild
+++ b/dev-ros/image_proc/image_proc-1.12.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,3 +27,4 @@ RDEPEND="
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gcc6.patch" )