summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 12:40:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 13:03:03 +0100
commit54581feca0a1c8bb0058e765365608ef6a90ebc8 (patch)
treee8a2b4d7f646e33de34338bb040869c01f0156d4 /dev-ros/image_view/image_view-1.12.15.ebuild
parentdev-ros/image_rotate: Bump to 1.12.15. (diff)
downloadgentoo-54581feca0a1c8bb0058e765365608ef6a90ebc8.tar.gz
gentoo-54581feca0a1c8bb0058e765365608ef6a90ebc8.tar.bz2
gentoo-54581feca0a1c8bb0058e765365608ef6a90ebc8.zip
dev-ros/image_view: Bump to 1.12.15.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_view/image_view-1.12.15.ebuild')
-rw-r--r--dev-ros/image_view/image_view-1.12.15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/image_view/image_view-1.12.15.ebuild b/dev-ros/image_view/image_view-1.12.15.ebuild
new file mode 100644
index 000000000000..1f5b4dd7a9df
--- /dev/null
+++ b/dev-ros/image_view/image_view-1.12.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Simple viewer for ROS image topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ media-libs/opencv
+ x11-libs/gtk+:2
+ dev-ros/camera_calibration_parsers
+ >=dev-ros/cv_bridge-1.11.10
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"