summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 14:30:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 14:33:40 +0200
commit551494ec2f617139e36676c8333df020c6340a1b (patch)
tree89bb44c5bb8e59f53c9600f6f24c8e6a53ea1e3c /dev-ros/imu_complementary_filter
parentdev-ros/imu_filter_madgwick: Remove old (diff)
downloadgentoo-551494ec2f617139e36676c8333df020c6340a1b.tar.gz
gentoo-551494ec2f617139e36676c8333df020c6340a1b.tar.bz2
gentoo-551494ec2f617139e36676c8333df020c6340a1b.zip
dev-ros/imu_complementary_filter: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/imu_complementary_filter')
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.2.ebuild10
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild12
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.2.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.2.ebuild
index e3d5c5217082..6c1525c19499 100644
--- a/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.2.ebuild
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
KEYWORDS="~amd64"
@@ -9,7 +9,7 @@ ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+DESCRIPTION="Fuses angular velocities, accelerations, and magnetic readings from an IMU"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -17,11 +17,13 @@ IUSE=""
RDEPEND="
dev-ros/message_filters
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
dev-libs/boost:=
"
DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
dev-ros/cmake_modules
"
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
index d9eb91e64e14..6c1525c19499 100644
--- a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
KEYWORDS="~amd64"
@@ -9,7 +9,7 @@ ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+DESCRIPTION="Fuses angular velocities, accelerations, and magnetic readings from an IMU"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -17,11 +17,13 @@ IUSE=""
RDEPEND="
dev-ros/message_filters
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
dev-libs/boost:=
"
DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
dev-ros/cmake_modules
"