summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 14:07:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commit55817d10405287723737f398206ea33efc6c66d4 (patch)
tree8e4b39eb866305656e5be1fa1b12b719bd6bb40c /dev-ros/imu_processors
parentros-meta/geometry_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-55817d10405287723737f398206ea33efc6c66d4.tar.gz
gentoo-55817d10405287723737f398206ea33efc6c66d4.tar.bz2
gentoo-55817d10405287723737f398206ea33efc6c66d4.zip
dev-ros/imu_processors: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/imu_processors')
-rw-r--r--dev-ros/imu_processors/Manifest1
-rw-r--r--dev-ros/imu_processors/imu_processors-0.2.1.ebuild24
-rw-r--r--dev-ros/imu_processors/imu_processors-9999.ebuild24
-rw-r--r--dev-ros/imu_processors/metadata.xml5
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/imu_processors/Manifest b/dev-ros/imu_processors/Manifest
new file mode 100644
index 000000000000..dc8ff723c39d
--- /dev/null
+++ b/dev-ros/imu_processors/Manifest
@@ -0,0 +1 @@
+DIST imu_pipeline-0.2.1.tar.gz 7962 SHA256 91e0d491bd08dce8629876bf6005a1aaabcb130413ed749c4ab168e17f0118fa SHA512 43c990e3b5a813661111f15bbaf6101794480de0f5bd9af663ce48ebbcf75ee79fa388cf228216427e7ffcbc575a317f3b0ee3ae5b8e6cca2cc0cab736c139e4 WHIRLPOOL 189279d535c11add08df686ca84598f4e1c5a6a9835416b4f10bef2a85c192359da1795d52171d083d19cfee7e43ef011a676304046893d7f75d4a33a72c204c
diff --git a/dev-ros/imu_processors/imu_processors-0.2.1.ebuild b/dev-ros/imu_processors/imu_processors-0.2.1.ebuild
new file mode 100644
index 000000000000..4a7411597144
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-0.2.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/imu_processors/imu_processors-9999.ebuild b/dev-ros/imu_processors/imu_processors-9999.ebuild
new file mode 100644
index 000000000000..4a7411597144
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/imu_processors/metadata.xml b/dev-ros/imu_processors/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/imu_processors/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>