summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 16:00:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commit95a6f201a0413939bcb08d3410f126a580027932 (patch)
tree907ec86318d0f974e709002f017c654803e61711 /dev-ros/interval_intersection
parentdev-ros/calibration_estimation: Initial import. Ebuild by me. (diff)
downloadgentoo-95a6f201a0413939bcb08d3410f126a580027932.tar.gz
gentoo-95a6f201a0413939bcb08d3410f126a580027932.tar.bz2
gentoo-95a6f201a0413939bcb08d3410f126a580027932.zip
dev-ros/interval_intersection: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/Manifest1
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild30
-rw-r--r--dev-ros/interval_intersection/interval_intersection-9999.ebuild30
-rw-r--r--dev-ros/interval_intersection/metadata.xml5
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/Manifest b/dev-ros/interval_intersection/Manifest
new file mode 100644
index 000000000000..389070489594
--- /dev/null
+++ b/dev-ros/interval_intersection/Manifest
@@ -0,0 +1 @@
+DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
new file mode 100644
index 000000000000..273edb7e86b3
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/interval_intersection/interval_intersection-9999.ebuild b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
new file mode 100644
index 000000000000..273edb7e86b3
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/interval_intersection/metadata.xml b/dev-ros/interval_intersection/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/interval_intersection/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>