summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-23 16:19:41 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-23 16:30:23 +0100
commit24c3ecc2b7e7bfb6a86eb94faf2254d60b38822d (patch)
tree931dccbf34120500ea66a02ff2043c09d92b16b0 /dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild
parentdev-ros/collada_urdf: Bump to 1.11.9. (diff)
downloadgentoo-24c3ecc2b7e7bfb6a86eb94faf2254d60b38822d.tar.gz
gentoo-24c3ecc2b7e7bfb6a86eb94faf2254d60b38822d.tar.bz2
gentoo-24c3ecc2b7e7bfb6a86eb94faf2254d60b38822d.zip
dev-ros/joint_state_publisher: Bump to 1.11.9.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild
new file mode 100644
index 000000000000..c536693a99c1
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.11.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${PYTHON_USEDEP}]
+"