summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 17:44:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:30:50 +0200
commit79641ee355fa5b99d216a08b85e44cf6a4096c83 (patch)
tree9f56c21c5842a2b8497b7c58237da575e565b440 /dev-ros/laser_proc/laser_proc-0.1.6.ebuild
parentdev-ros/mavlink-gbp-release: Remove old (diff)
downloadgentoo-79641ee355fa5b99d216a08b85e44cf6a4096c83.tar.gz
gentoo-79641ee355fa5b99d216a08b85e44cf6a4096c83.tar.bz2
gentoo-79641ee355fa5b99d216a08b85e44cf6a4096c83.zip
dev-ros/laser_proc: bump to 0.1.6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/laser_proc/laser_proc-0.1.6.ebuild')
-rw-r--r--dev-ros/laser_proc/laser_proc-0.1.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/laser_proc/laser_proc-0.1.6.ebuild b/dev-ros/laser_proc/laser_proc-0.1.6.ebuild
new file mode 100644
index 000000000000..2609d02c2feb
--- /dev/null
+++ b/dev-ros/laser_proc/laser_proc-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/laser_proc"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts representations of LaserScan and MultiEchoLaserScan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/pluginlib
+ dev-ros/nodelet
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"