summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-18 21:15:07 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 21:15:07 +0200
commitfd799a3a19d21476c83f936709e177928fa55359 (patch)
tree215353f2e1d8b3b4cf36980bfda69016975fedea /dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild
parentdev-ros/message_filters: Depend on dev-libs/boost:=[threads(+)] (diff)
downloadgentoo-fd799a3a19d21476c83f936709e177928fa55359.tar.gz
gentoo-fd799a3a19d21476c83f936709e177928fa55359.tar.bz2
gentoo-fd799a3a19d21476c83f936709e177928fa55359.zip
dev-ros/monocam_settler: Depend on dev-libs/boost:=[threads(+)]
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild')
-rw-r--r--dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild b/dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild
new file mode 100644
index 000000000000..6826337aa05f
--- /dev/null
+++ b/dev-ros/monocam_settler/monocam_settler-0.10.14-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+ dev-ros/settlerlib
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"