summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:56:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit451aa564a8b2995e4c58578a4331565f38f86a24 (patch)
tree80acec72ac24885cc51fc7735b21d39c2cd13245 /dev-ros/move_slow_and_clear
parentdev-ros/rotate_recovery: Initial import. Ebuild by me. (diff)
downloadgentoo-451aa564a8b2995e4c58578a4331565f38f86a24.tar.gz
gentoo-451aa564a8b2995e4c58578a4331565f38f86a24.tar.bz2
gentoo-451aa564a8b2995e4c58578a4331565f38f86a24.zip
dev-ros/move_slow_and_clear: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/move_slow_and_clear')
-rw-r--r--dev-ros/move_slow_and_clear/Manifest1
-rw-r--r--dev-ros/move_slow_and_clear/metadata.xml5
-rw-r--r--dev-ros/move_slow_and_clear/move_slow_and_clear-1.13.0.ebuild31
-rw-r--r--dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild31
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ros/move_slow_and_clear/Manifest b/dev-ros/move_slow_and_clear/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/move_slow_and_clear/metadata.xml b/dev-ros/move_slow_and_clear/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/move_slow_and_clear/move_slow_and_clear-1.13.0.ebuild b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.13.0.ebuild
new file mode 100644
index 000000000000..18fca39ec649
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Move slow and clear"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+
+"
diff --git a/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild b/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild
new file mode 100644
index 000000000000..18fca39ec649
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/move_slow_and_clear-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Move slow and clear"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+
+"