summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-31 13:25:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-31 15:09:11 +0200
commitea0213f79cda59daeba96347c4b226ff874a56eb (patch)
tree782e599ad5f7d644183767fb65a48dd38465da39 /dev-ros/navfn
parentdev-ros/nav_core: Bump to 1.16.1. (diff)
downloadgentoo-ea0213f79cda59daeba96347c4b226ff874a56eb.tar.gz
gentoo-ea0213f79cda59daeba96347c4b226ff874a56eb.tar.bz2
gentoo-ea0213f79cda59daeba96347c4b226ff874a56eb.zip
dev-ros/navfn: Bump to 1.16.1.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/navfn')
-rw-r--r--dev-ros/navfn/Manifest1
-rw-r--r--dev-ros/navfn/navfn-1.16.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/navfn/Manifest b/dev-ros/navfn/Manifest
index 4a97915f4fab..cc2197df1073 100644
--- a/dev-ros/navfn/Manifest
+++ b/dev-ros/navfn/Manifest
@@ -1 +1,2 @@
DIST navigation-1.16.0.tar.gz 336708 BLAKE2B 74fdc7c3afb00bfbded011678c90b22cc95fe45b126c9a8a4bb9a80f8676ed0ade32e02ad77ec643f167d9719e71347750b6f7993f61cf743fc018d1412436d6 SHA512 ee6336627c2e095ef089534c19b7258f394858a6c04ad49b3aa6e1d0acca67c245c2743f04752be137864dba216c3aa38e34c3e40e3db7839308be3adbc808d6
+DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
diff --git a/dev-ros/navfn/navfn-1.16.1.ebuild b/dev-ros/navfn/navfn-1.16.1.ebuild
new file mode 100644
index 000000000000..da9427d6977b
--- /dev/null
+++ b/dev-ros/navfn/navfn-1.16.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+
+ dev-cpp/eigen:3
+ x11-libs/fltk
+ media-libs/netpbm
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )