summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 11:22:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 11:44:14 +0200
commitf3bfb469a41e6eab3ade70f69b1c5d1c0443e19b (patch)
treed4eff47ac72be2b659b4bb013386a6f41576cc41 /dev-ros/opencv_apps/opencv_apps-9999.ebuild
parentdev-ros/camera_info_manager: Initial import. Ebuild by me. (diff)
downloadgentoo-f3bfb469a41e6eab3ade70f69b1c5d1c0443e19b.tar.gz
gentoo-f3bfb469a41e6eab3ade70f69b1c5d1c0443e19b.tar.bz2
gentoo-f3bfb469a41e6eab3ade70f69b1c5d1c0443e19b.zip
dev-ros/opencv_apps: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/opencv_apps/opencv_apps-9999.ebuild')
-rw-r--r--dev-ros/opencv_apps/opencv_apps-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/opencv_apps/opencv_apps-9999.ebuild b/dev-ros/opencv_apps/opencv_apps-9999.ebuild
new file mode 100644
index 000000000000..cfea26daf0b4
--- /dev/null
+++ b/dev-ros/opencv_apps/opencv_apps-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+
+inherit ros-catkin
+
+DESCRIPTION="OpenCV applications for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"