summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-01-24 18:05:01 +0100
committerJakov Smolić <jsmolic@gentoo.org>2023-01-24 21:14:30 +0100
commit605a0587152fedad32c9f275ca3b107854e2eee3 (patch)
tree9f997c2fadec06ec06d40f64d223f8e4e0dc2bab /dev-ros/pcl_conversions
parentdev-ros/openslam_gmapping: treeclean (diff)
downloadgentoo-605a0587152fedad32c9f275ca3b107854e2eee3.tar.gz
gentoo-605a0587152fedad32c9f275ca3b107854e2eee3.tar.bz2
gentoo-605a0587152fedad32c9f275ca3b107854e2eee3.zip
dev-ros/pcl_conversions: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-ros/pcl_conversions')
-rw-r--r--dev-ros/pcl_conversions/Manifest2
-rw-r--r--dev-ros/pcl_conversions/files/pcl.patch68
-rw-r--r--dev-ros/pcl_conversions/metadata.xml11
-rw-r--r--dev-ros/pcl_conversions/pcl_conversions-1.7.2-r1.ebuild26
-rw-r--r--dev-ros/pcl_conversions/pcl_conversions-1.7.4.ebuild25
-rw-r--r--dev-ros/pcl_conversions/pcl_conversions-9999.ebuild25
6 files changed, 0 insertions, 157 deletions
diff --git a/dev-ros/pcl_conversions/Manifest b/dev-ros/pcl_conversions/Manifest
deleted file mode 100644
index 0c6be94ce683..000000000000
--- a/dev-ros/pcl_conversions/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST perception_pcl-1.7.2.tar.gz 81897 BLAKE2B 692f000337090c7a2354bf9626d391aa0fe390041042718e7dde7335c750137e7e1b6f939728ad1e2af3411e535ba63b42bc17f74b3535e38628f2b6c1c87036 SHA512 228b1d7d589bfd1460e8c58448b0d9257e86c1796b009853aeceeb1da20d8f46462d8c273a95804003ce3c43326c6575553d19b319aa9effcef4854347d5c3f9
-DIST perception_pcl-1.7.4.tar.gz 82160 BLAKE2B 11f4936da3d2fc86eafcc1219e4bd4acf0defece3f2dfcefea54ad3e239fc3a87c3a581291f5cd3adae74c0b6093213cff50ee1cfc7b87b1006299457773d2a8 SHA512 ee5b03dd348de2c589ec01bcab165959dc1e177abd3a2beca62bf701854231296a18052142273c6b4965101fe1b72ee685884049b45d93aa452397bb2df640f4
diff --git a/dev-ros/pcl_conversions/files/pcl.patch b/dev-ros/pcl_conversions/files/pcl.patch
deleted file mode 100644
index fc0ef8866863..000000000000
--- a/dev-ros/pcl_conversions/files/pcl.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 6900f7cf650e6c0df2aef45e0011833905b0ba9e Mon Sep 17 00:00:00 2001
-From: Markus Vieth <39675748+mvieth@users.noreply.github.com>
-Date: Fri, 6 Nov 2020 19:13:16 +0100
-Subject: [PATCH] Change conversions of Vertices for new PCL versions (#313)
-
-In https://github.com/PointCloudLibrary/pcl/commit/ad00c7bee2fad0391649479d90eee4461a2e74e7, the vertices field of pcl::Vertices changed from std::vector<std::uint32_t> to std::vector<pcl::index_t>, where index_t is an index type with configurable size (currently by default int). This commit makes conversions from and to pcl_msgs::Vertices possible again, moving the vector contents if possible.
----
- .../include/pcl_conversions/pcl_conversions.h | 23 +++++++++++++++----
- 1 file changed, 19 insertions(+), 4 deletions(-)
-
-diff --git a/pcl_conversions/include/pcl_conversions/pcl_conversions.h b/pcl_conversions/include/pcl_conversions/pcl_conversions.h
-index a5671c25..5ac0a41a 100644
---- a/include/pcl_conversions/pcl_conversions.h
-+++ b/include/pcl_conversions/pcl_conversions.h
-@@ -350,10 +350,25 @@ namespace pcl_conversions {
-
- /** pcl::Vertices <=> pcl_msgs::Vertices **/
-
-+ namespace internal
-+ {
-+ template <class T>
-+ inline void move(std::vector<T> &a, std::vector<T> &b)
-+ {
-+ b.swap(a);
-+ }
-+
-+ template <class T1, class T2>
-+ inline void move(std::vector<T1> &a, std::vector<T2> &b)
-+ {
-+ b.assign(a.cbegin(), a.cend());
-+ }
-+ }
-+
- inline
- void fromPCL(const pcl::Vertices &pcl_vert, pcl_msgs::Vertices &vert)
- {
-- vert.vertices = pcl_vert.vertices;
-+ vert.vertices.assign(pcl_vert.vertices.cbegin(), pcl_vert.vertices.cend());
- }
-
- inline
-@@ -370,7 +385,7 @@ namespace pcl_conversions {
- inline
- void moveFromPCL(pcl::Vertices &pcl_vert, pcl_msgs::Vertices &vert)
- {
-- vert.vertices.swap(pcl_vert.vertices);
-+ internal::move(pcl_vert.vertices, vert.vertices);
- }
-
- inline
-@@ -387,7 +402,7 @@ namespace pcl_conversions {
- inline
- void toPCL(const pcl_msgs::Vertices &vert, pcl::Vertices &pcl_vert)
- {
-- pcl_vert.vertices = vert.vertices;
-+ pcl_vert.vertices.assign(vert.vertices.cbegin(), vert.vertices.cend());
- }
-
- inline
-@@ -404,7 +419,7 @@ namespace pcl_conversions {
- inline
- void moveToPCL(pcl_msgs::Vertices &vert, pcl::Vertices &pcl_vert)
- {
-- pcl_vert.vertices.swap(vert.vertices);
-+ internal::move(vert.vertices, pcl_vert.vertices);
- }
-
- inline
diff --git a/dev-ros/pcl_conversions/metadata.xml b/dev-ros/pcl_conversions/metadata.xml
deleted file mode 100644
index 57f3ccdd6493..000000000000
--- a/dev-ros/pcl_conversions/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros-perception/perception_pcl</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ros/pcl_conversions/pcl_conversions-1.7.2-r1.ebuild b/dev-ros/pcl_conversions/pcl_conversions-1.7.2-r1.ebuild
deleted file mode 100644
index ec80ff5fa28b..000000000000
--- a/dev-ros/pcl_conversions/pcl_conversions-1.7.2-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
-ROS_SUBDIR=${PN}
-KEYWORDS="~amd64 ~arm"
-
-inherit ros-catkin
-
-DESCRIPTION="Provides conversions from PCL data types and ROS message types"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- sci-libs/pcl:=
-"
-DEPEND="${RDEPEND}
- dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3
- test? ( dev-cpp/gtest )"
-PATCHES=("${FILESDIR}/pcl.patch")
diff --git a/dev-ros/pcl_conversions/pcl_conversions-1.7.4.ebuild b/dev-ros/pcl_conversions/pcl_conversions-1.7.4.ebuild
deleted file mode 100644
index 0cf5c845fbc9..000000000000
--- a/dev-ros/pcl_conversions/pcl_conversions-1.7.4.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
-ROS_SUBDIR=${PN}
-KEYWORDS="~amd64 ~arm"
-
-inherit ros-catkin
-
-DESCRIPTION="Provides conversions from PCL data types and ROS message types"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- sci-libs/pcl:=
-"
-DEPEND="${RDEPEND}
- dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3
- test? ( dev-cpp/gtest )"
diff --git a/dev-ros/pcl_conversions/pcl_conversions-9999.ebuild b/dev-ros/pcl_conversions/pcl_conversions-9999.ebuild
deleted file mode 100644
index 2aa2de1919aa..000000000000
--- a/dev-ros/pcl_conversions/pcl_conversions-9999.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-perception/perception_pcl"
-ROS_SUBDIR=${PN}
-KEYWORDS="~amd64 ~arm"
-
-inherit ros-catkin
-
-DESCRIPTION="Provides conversions from PCL data types and ROS message types"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roscpp
- sci-libs/pcl:=
-"
-DEPEND="${RDEPEND}
- dev-ros/pcl_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-cpp/eigen:3
- test? ( dev-cpp/gtest )"