summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:46 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-05-13 12:48:59 +0200
commitc71f7eb0abb685c1bdf5d1816bae8db36a7d0a97 (patch)
tree5ab8f60a566bbd9faf7e04698549cd79f71b6174 /dev-ros/pluginlib/pluginlib-1.12.1.ebuild
parentdev-ros/pluginlib: Remove old (diff)
downloadgentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.tar.gz
gentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.tar.bz2
gentoo-c71f7eb0abb685c1bdf5d1816bae8db36a7d0a97.zip
dev-ros/pluginlib: bump to 1.12.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ros/pluginlib/pluginlib-1.12.1.ebuild')
-rw-r--r--dev-ros/pluginlib/pluginlib-1.12.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/pluginlib-1.12.1.ebuild b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )