summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-07 16:55:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-07 17:32:46 +0200
commit1e46e6c63050420c88561ff48cff5d65f92e3f04 (patch)
tree975d8ba5e0e4b29860388d080d3ef40275a80ebb /dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild
parentdev-ros/rosauth: fix tests (diff)
downloadgentoo-1e46e6c63050420c88561ff48cff5d65f92e3f04.tar.gz
gentoo-1e46e6c63050420c88561ff48cff5d65f92e3f04.tar.bz2
gentoo-1e46e6c63050420c88561ff48cff5d65f92e3f04.zip
dev-ros/pluginlib: add subslot
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild')
-rw-r--r--dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild b/dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild
new file mode 100644
index 000000000000..7dc414eb606d
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.13.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for writing and dynamically loading plugins using the ROS infrastructure"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" "${FILESDIR}/libdir.patch" )
+
+src_test() {
+ cmake_build tests
+
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH=devel/
+ ros-catkin_src_test
+}