summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-30 15:31:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-30 15:32:45 +0200
commit647a40e39d67c4631a671313184018650f42837a (patch)
treec67f09e04bd7f924280207e1f5d4bccd2ddb78f0 /dev-ros/pluginlib
parentdev-ros/pluginlib: Remove old (diff)
downloadgentoo-647a40e39d67c4631a671313184018650f42837a.tar.gz
gentoo-647a40e39d67c4631a671313184018650f42837a.tar.bz2
gentoo-647a40e39d67c4631a671313184018650f42837a.zip
dev-ros/pluginlib: bump to 1.11.3
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-ros/pluginlib')
-rw-r--r--dev-ros/pluginlib/Manifest1
-rw-r--r--dev-ros/pluginlib/pluginlib-1.11.3.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index dbfdb06e59f8..c1443be2bcc6 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1 +1,2 @@
DIST pluginlib-1.11.2.tar.gz 22844 BLAKE2B 3f3090b2b41754c0989cbc2c0f31333cf404aca00c481c3062955b01274b1cddb76eef41a0bce9a01058b461a293d42beae7c9337e8780d1e9503968196f0a98 SHA512 579aeb2ae82d6607c62007a5be6ccc402856c135e69a500d530ce5569c4f77526a63fee8b948db997db2face37bdac929b58911b5245c6ad641d19af055e46c0
+DIST pluginlib-1.11.3.tar.gz 23465 BLAKE2B 64725b7bd3896362168db324dbbdc9a0de24d6c79b77d3b21e6d6a95091bfe7bca35fe93617200ed993a20aa8ce5604b90eadf546ca0d3ab5cca79dd47e182a0 SHA512 5d0acadf69362137041b6f08724ef0c0b0209ca901d1d082df38224e08ad990e43133979e9462128f0b9fb313ad4c9398bf5c075e5669a1cd3cd8dd715e9355b
diff --git a/dev-ros/pluginlib/pluginlib-1.11.3.ebuild b/dev-ros/pluginlib/pluginlib-1.11.3.ebuild
new file mode 100644
index 000000000000..01682d753b10
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.11.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ dev-ros/cmake_modules
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )