summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:47:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:47:21 +0200
commitce7be0365511d3b0361b30b0bae5e6c094cba5fd (patch)
tree76310f309fc70d759659eb087de4141435beafeb /dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild
parentdev-ros/pr2_machine: Initial import. Ebuild by me. (diff)
downloadgentoo-ce7be0365511d3b0361b30b0bae5e6c094cba5fd.tar.gz
gentoo-ce7be0365511d3b0361b30b0bae5e6c094cba5fd.tar.bz2
gentoo-ce7be0365511d3b0361b30b0bae5e6c094cba5fd.zip
dev-ros/pr2_dashboard_aggregator: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild')
-rw-r--r--dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild
new file mode 100644
index 000000000000..35693d7f2669
--- /dev/null
+++ b/dev-ros/pr2_dashboard_aggregator/pr2_dashboard_aggregator-1.11.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Aggregates all of the topics that a 'pr2_dashboard' app might be interested in"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/pr2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"