summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 17:43:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:57 +0200
commitb97b6ae03fc5623ee75d66f22e5e1ea9aa53778c (patch)
tree3978009cb05d268d0d55325773f15dedd6b541b0 /dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
parentros-meta/qt_gui_core: Bump to 0.3.10. (diff)
downloadgentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.tar.gz
gentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.tar.bz2
gentoo-b97b6ae03fc5623ee75d66f22e5e1ea9aa53778c.zip
dev-ros/python_qt_binding: bump to 0.3.4
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
new file mode 100644
index 000000000000..c7463631a14c
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"