summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-01 07:25:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-01 07:29:20 +0200
commitb318c82a7c38bef91d63bd652eb041f261f9446b (patch)
tree136ca4cd0ac7484e19ade8b877e7428583d238c5 /dev-ros/qt_gui/qt_gui-0.2.30.ebuild
parentdev-ros/qt_dotgraph: Bump to 0.2.30. (diff)
downloadgentoo-b318c82a7c38bef91d63bd652eb041f261f9446b.tar.gz
gentoo-b318c82a7c38bef91d63bd652eb041f261f9446b.tar.bz2
gentoo-b318c82a7c38bef91d63bd652eb041f261f9446b.zip
dev-ros/qt_gui: Bump to 0.2.30.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_gui/qt_gui-0.2.30.ebuild')
-rw-r--r--dev-ros/qt_gui/qt_gui-0.2.30.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/qt_gui/qt_gui-0.2.30.ebuild b/dev-ros/qt_gui/qt_gui-0.2.30.ebuild
new file mode 100644
index 000000000000..c65766bd2aa5
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.2.30.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"