summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:45:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 14:52:48 +0200
commitd917f1983b4a877be47afe6aa9d45b626eb0c32b (patch)
tree7d53b795c4aee0c3d46d9b3750e87d38551d2ea7 /dev-ros/qt_gui/qt_gui-0.3.1.ebuild
parentdev-ros/qt_dotgraph: Bump to 0.3.1. (diff)
downloadgentoo-d917f1983b4a877be47afe6aa9d45b626eb0c32b.tar.gz
gentoo-d917f1983b4a877be47afe6aa9d45b626eb0c32b.tar.bz2
gentoo-d917f1983b4a877be47afe6aa9d45b626eb0c32b.zip
dev-ros/qt_gui: Bump to 0.3.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/qt_gui/qt_gui-0.3.1.ebuild')
-rw-r--r--dev-ros/qt_gui/qt_gui-0.3.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/qt_gui/qt_gui-0.3.1.ebuild b/dev-ros/qt_gui/qt_gui-0.3.1.ebuild
new file mode 100644
index 000000000000..f5ef4e6552db
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"