summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-31 12:40:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-31 15:56:47 +0200
commit254e8d005de7bc2e537eae4978c3e6ccae644a1c (patch)
treeafeb694d947a5b0b649051c4a6670a45f9c015f4 /dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild
parentdev-ros/qt_gui_app: Bump to 0.3.11. (diff)
downloadgentoo-254e8d005de7bc2e537eae4978c3e6ccae644a1c.tar.gz
gentoo-254e8d005de7bc2e537eae4978c3e6ccae644a1c.tar.bz2
gentoo-254e8d005de7bc2e537eae4978c3e6ccae644a1c.zip
dev-ros/qt_gui_cpp: Bump to 0.3.11.
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild')
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild
new file mode 100644
index 000000000000..a52422eff7b2
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ >=dev-ros/pluginlib-1.9.23
+ dev-libs/tinyxml2:=
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)