summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 12:59:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 12:59:09 +0100
commit6e533a4d2b12cf8f72caa2adfb2a9326d27bfe10 (patch)
tree931f1b58e02999a468bd4f715e74cfc0f968848e /dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.3.16. (diff)
downloadgentoo-6e533a4d2b12cf8f72caa2adfb2a9326d27bfe10.tar.gz
gentoo-6e533a4d2b12cf8f72caa2adfb2a9326d27bfe10.tar.bz2
gentoo-6e533a4d2b12cf8f72caa2adfb2a9326d27bfe10.zip
dev-ros/qt_gui_py_common: Bump to 0.3.16.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild
new file mode 100644
index 000000000000..7933e8e1843c
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.16.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"