summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:07:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:43 +0200
commit97309eda746218fec2a5cdfc4de4338c2800a657 (patch)
tree002d832f72d3c0cff1f000966800f9dec5fd3875 /dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild
parentdev-ros/qt_gui_cpp: Bump to 0.3.5. (diff)
downloadgentoo-97309eda746218fec2a5cdfc4de4338c2800a657.tar.gz
gentoo-97309eda746218fec2a5cdfc4de4338c2800a657.tar.bz2
gentoo-97309eda746218fec2a5cdfc4de4338c2800a657.zip
dev-ros/qt_gui_py_common: Bump to 0.3.5.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild
new file mode 100644
index 000000000000..87a1c621b8d2
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.5.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"