summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 09:34:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 09:34:01 +0200
commit4e9d8e75cf413993635be5dbf2a24da6628f9129 (patch)
tree578a2646fd76562855b1466fcced27f808934c9d /dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild
parentros-meta/ros_control: remove old (diff)
downloadgentoo-4e9d8e75cf413993635be5dbf2a24da6628f9129.tar.gz
gentoo-4e9d8e75cf413993635be5dbf2a24da6628f9129.tar.bz2
gentoo-4e9d8e75cf413993635be5dbf2a24da6628f9129.zip
dev-ros/realtime_tools: bump to 1.9.2
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild')
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild b/dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild
new file mode 100644
index 000000000000..52e27bb666bc
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.9.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"