summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-30 10:05:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-30 10:29:51 +0200
commit9f7f097a9139a955209864b589c5a92e63e74a39 (patch)
tree2a0ccc68374ae12cba563cd3a4660710db33ae38 /dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
parentdev-ros/resource_retriever: remove old (diff)
downloadgentoo-9f7f097a9139a955209864b589c5a92e63e74a39.tar.gz
gentoo-9f7f097a9139a955209864b589c5a92e63e74a39.tar.bz2
gentoo-9f7f097a9139a955209864b589c5a92e63e74a39.zip
dev-ros/resource_retriever: bump to 1.12.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild')
-rw-r--r--dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild b/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
new file mode 100644
index 000000000000..0a3c5907b1e1
--- /dev/null
+++ b/dev-ros/resource_retriever/resource_retriever-1.12.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/resource_retriever"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves data from url-format files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ net-misc/curl
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"