summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 12:03:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 14:24:40 +0200
commit4eefdfa92e99b918b04aff0ccb24d562021de828 (patch)
tree37e68d9181f7ce688a29a0c3e67f42b046dcccbb /dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
parentarch/arm/use.mask: -bs2b -librtmp -bluray -aacplus (diff)
downloadgentoo-4eefdfa92e99b918b04aff0ccb24d562021de828.tar.gz
gentoo-4eefdfa92e99b918b04aff0ccb24d562021de828.tar.bz2
gentoo-4eefdfa92e99b918b04aff0ccb24d562021de828.zip
dev-ros/resource_retriever: Bump to 1.12.3 and update live ebuild
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild')
-rw-r--r--dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild b/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
new file mode 100644
index 000000000000..5afee13f126e
--- /dev/null
+++ b/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/resource_retriever"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves data from url-format files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ net-misc/curl
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"