summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 10:23:03 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 10:23:16 +0100
commit7b9b8646a826262d8f092c4b0cca4c6e4de81603 (patch)
tree71d43b70f07ae12fc73aab50453c04fe8a8be455 /dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild
parentsci-libs/rtabmap: Bump to 0.10.10 (diff)
downloadgentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.tar.gz
gentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.tar.bz2
gentoo-7b9b8646a826262d8f092c4b0cca4c6e4de81603.zip
dev-ros/robot_pose_publisher: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild')
-rw-r--r--dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild b/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild
new file mode 100644
index 000000000000..ae81a9889c3c
--- /dev/null
+++ b/dev-ros/robot_pose_publisher/robot_pose_publisher-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/WPI-RAIL/robot_pose_publisher"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A Simple Node to Publish the Robot's Position Relative to the Map using TFs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"