summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 17:50:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 18:57:09 +0200
commit66b436980e8ad49f846f8602ef7cd60f62ec015f (patch)
treeb40f3305f8323001e0d6c220e9620d685b525527 /dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild
parentdev-ros/ros_environment: Remove old (diff)
downloadgentoo-66b436980e8ad49f846f8602ef7cd60f62ec015f.tar.gz
gentoo-66b436980e8ad49f846f8602ef7cd60f62ec015f.tar.bz2
gentoo-66b436980e8ad49f846f8602ef7cd60f62ec015f.zip
dev-ros/robot_state_publisher: bump to 1.15.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild')
-rw-r--r--dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild b/dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild
new file mode 100644
index 000000000000..4a42bc612e92
--- /dev/null
+++ b/dev-ros/robot_state_publisher/robot_state_publisher-1.15.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/robot_state_publisher"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Package for publishing the state of a robot to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/kdl_parser
+ dev-cpp/eigen:3
+ sci-libs/orocos_kdl:=
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/rostime
+ dev-ros/tf2_ros
+ dev-ros/tf2_kdl
+ dev-ros/kdl_conversions
+ dev-ros/sensor_msgs
+ dev-ros/tf
+ dev-ros/urdf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )
+"