summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 11:49:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commita538515629ec59805e8514b9b567766b256f9837 (patch)
tree6ba98c2f9d755933c02cda8c30a84ee048d62c40 /dev-ros/rosbag/rosbag-1.11.17.ebuild
parentdev-ros/message_filters: Bump to 1.11.17. (diff)
downloadgentoo-a538515629ec59805e8514b9b567766b256f9837.tar.gz
gentoo-a538515629ec59805e8514b9b567766b256f9837.tar.bz2
gentoo-a538515629ec59805e8514b9b567766b256f9837.zip
dev-ros/rosbag: Bump to 1.11.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbag/rosbag-1.11.17.ebuild')
-rw-r--r--dev-ros/rosbag/rosbag-1.11.17.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rosbag/rosbag-1.11.17.ebuild b/dev-ros/rosbag/rosbag-1.11.17.ebuild
new file mode 100644
index 000000000000..e6e5ada3ad7e
--- /dev/null
+++ b/dev-ros/rosbag/rosbag-1.11.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+ dev-ros/rosbag_storage
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/topic_tools
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/genpy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"