summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:29:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commitb24fb848f149d564d331c06f75a3f128856c1a95 (patch)
tree554b649a69b014d2dbcd28ccdd2901d7f0d12422 /dev-ros/rosbash
parentdev-ros/roslib: Bump rospkg dep. (diff)
downloadgentoo-b24fb848f149d564d331c06f75a3f128856c1a95.tar.gz
gentoo-b24fb848f149d564d331c06f75a3f128856c1a95.tar.bz2
gentoo-b24fb848f149d564d331c06f75a3f128856c1a95.zip
dev-ros/rosbash: Fix catking prefix patch.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rosbash')
-rw-r--r--dev-ros/rosbash/files/catkin_prefix2.patch13
-rw-r--r--dev-ros/rosbash/rosbash-1.12.5.ebuild2
-rw-r--r--dev-ros/rosbash/rosbash-9999.ebuild2
3 files changed, 15 insertions, 2 deletions
diff --git a/dev-ros/rosbash/files/catkin_prefix2.patch b/dev-ros/rosbash/files/catkin_prefix2.patch
new file mode 100644
index 000000000000..f36a7c7d6f08
--- /dev/null
+++ b/dev-ros/rosbash/files/catkin_prefix2.patch
@@ -0,0 +1,13 @@
+Index: ros-1.12.5/tools/rosbash/scripts/rosrun
+===================================================================
+--- ros-1.12.5.orig/tools/rosbash/scripts/rosrun
++++ ros-1.12.5/tools/rosbash/scripts/rosrun
+@@ -47,7 +47,7 @@ case $2 in
+ ;;
+ esac
+
+-if [[ -n $CMAKE_PREFIX_PATH ]]; then
++if [[ -n $CMAKE_PREFIX_PATH || -n $CATKIN_PREFIX_PATH ]]; then
+ IFS=$'\n'
+ catkin_package_libexec_dirs=(`catkin_find --without-underlays --libexec --share "$1" 2> /dev/null`)
+ unset IFS
diff --git a/dev-ros/rosbash/rosbash-1.12.5.ebuild b/dev-ros/rosbash/rosbash-1.12.5.ebuild
index 300eb4bfbfa5..568560755492 100644
--- a/dev-ros/rosbash/rosbash-1.12.5.ebuild
+++ b/dev-ros/rosbash/rosbash-1.12.5.ebuild
@@ -17,4 +17,4 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix2.patch" )
diff --git a/dev-ros/rosbash/rosbash-9999.ebuild b/dev-ros/rosbash/rosbash-9999.ebuild
index 300eb4bfbfa5..568560755492 100644
--- a/dev-ros/rosbash/rosbash-9999.ebuild
+++ b/dev-ros/rosbash/rosbash-9999.ebuild
@@ -17,4 +17,4 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix2.patch" )