summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-21 16:25:09 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-21 16:51:31 +0100
commit0393c428c236f0408910faea4d3875aa4a1ef375 (patch)
tree637510003da5f6d1928927d790fff9b93f7b51ea /dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild
parentdev-ros/rosbridge_library: Bump to 0.10.1. (diff)
downloadgentoo-0393c428c236f0408910faea4d3875aa4a1ef375.tar.gz
gentoo-0393c428c236f0408910faea4d3875aa4a1ef375.tar.bz2
gentoo-0393c428c236f0408910faea4d3875aa4a1ef375.zip
dev-ros/rosbridge_server: Bump to 0.10.1.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild')
-rw-r--r--dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild b/dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild
new file mode 100644
index 000000000000..9fe85a462e1a
--- /dev/null
+++ b/dev-ros/rosbridge_server/rosbridge_server-0.10.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A WebSocket interface to rosbridge"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosapi[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosauth[${PYTHON_USEDEP}]
+ dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"