summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:02:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:48 +0200
commita91f0076adee35958c32e732b6826db0ed10e190 (patch)
tree934784023fa1111a07f3fbf597877c93b95ac3f2 /dev-ros/rosconsole/rosconsole-1.13.7.ebuild
parentdev-ros/rosconsole: update to new split repo (diff)
downloadgentoo-a91f0076adee35958c32e732b6826db0ed10e190.tar.gz
gentoo-a91f0076adee35958c32e732b6826db0ed10e190.tar.bz2
gentoo-a91f0076adee35958c32e732b6826db0ed10e190.zip
dev-ros/rosconsole: bump to 1.13.7
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-1.13.7.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-1.13.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/rosconsole-1.13.7.ebuild b/dev-ros/rosconsole/rosconsole-1.13.7.ebuild
new file mode 100644
index 000000000000..184a614f8a0c
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-1.13.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rosconsole"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}