summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-23 09:23:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-23 10:15:51 +0100
commitbdc45dfbadce146c159b6b4d206960a13a5a0beb (patch)
tree2f226ff649f283c986561ea041956d355c62cedc /dev-ros/roscreate/roscreate-1.14.0.ebuild
parentdev-ros/rosclean: Bump to 1.14.0. (diff)
downloadgentoo-bdc45dfbadce146c159b6b4d206960a13a5a0beb.tar.gz
gentoo-bdc45dfbadce146c159b6b4d206960a13a5a0beb.tar.bz2
gentoo-bdc45dfbadce146c159b6b4d206960a13a5a0beb.zip
dev-ros/roscreate: Bump to 1.14.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/roscreate/roscreate-1.14.0.ebuild')
-rw-r--r--dev-ros/roscreate/roscreate-1.14.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.14.0.ebuild b/dev-ros/roscreate/roscreate-1.14.0.ebuild
new file mode 100644
index 000000000000..1824c85cccf1
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.14.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"