summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 09:59:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:49 +0100
commited749312fbc07450c0e8cdaa59b715cb16174caf (patch)
tree368f3446e53a8f4695166f3881f1746e421bece2 /dev-ros/rosgraph/rosgraph-1.13.0.ebuild
parentdev-ros/rosconsole: Bump to 1.13.0. (diff)
downloadgentoo-ed749312fbc07450c0e8cdaa59b715cb16174caf.tar.gz
gentoo-ed749312fbc07450c0e8cdaa59b715cb16174caf.tar.bz2
gentoo-ed749312fbc07450c0e8cdaa59b715cb16174caf.zip
dev-ros/rosgraph: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.13.0.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.13.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.13.0.ebuild b/dev-ros/rosgraph/rosgraph-1.13.0.ebuild
new file mode 100644
index 000000000000..f232c81cf629
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.13.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"