summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-20 11:54:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-20 14:43:55 +0200
commitf3e40f65e355f1ff933eadbbe73b3515708a90eb (patch)
tree3e9ff72076d56ebc91fb28e7dbb04e8f41f21572 /dev-ros/rosgraph/rosgraph-1.15.9.ebuild
parentdev-ros/rosbag_storage: Bump to 1.15.9. (diff)
downloadgentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.tar.gz
gentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.tar.bz2
gentoo-f3e40f65e355f1ff933eadbbe73b3515708a90eb.zip
dev-ros/rosgraph: Bump to 1.15.9.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.15.9.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.15.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.15.9.ebuild b/dev-ros/rosgraph/rosgraph-1.15.9.ebuild
new file mode 100644
index 000000000000..171218629338
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.15.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/netifaces[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}