summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-24 14:26:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-24 15:44:31 +0200
commit7fe021fbd6aca61789cfd58bfd298c945ce4343b (patch)
tree6e0b3f5bd5eb0a6c00a29ab46f53f38eaa925346 /dev-ros/rosgraph
parentdev-ros/rosgraph: Remove old (diff)
downloadgentoo-7fe021fbd6aca61789cfd58bfd298c945ce4343b.tar.gz
gentoo-7fe021fbd6aca61789cfd58bfd298c945ce4343b.tar.bz2
gentoo-7fe021fbd6aca61789cfd58bfd298c945ce4343b.zip
dev-ros/rosgraph: fix tests
Closes: https://bugs.gentoo.org/738588 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.15.8.ebuild5
-rw-r--r--dev-ros/rosgraph/rosgraph-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.15.8.ebuild b/dev-ros/rosgraph/rosgraph-1.15.8.ebuild
index 0266daff9c69..171218629338 100644
--- a/dev-ros/rosgraph/rosgraph-1.15.8.ebuild
+++ b/dev-ros/rosgraph/rosgraph-1.15.8.ebuild
@@ -23,3 +23,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosgraph/rosgraph-9999.ebuild b/dev-ros/rosgraph/rosgraph-9999.ebuild
index 0266daff9c69..171218629338 100644
--- a/dev-ros/rosgraph/rosgraph-9999.ebuild
+++ b/dev-ros/rosgraph/rosgraph-9999.ebuild
@@ -23,3 +23,8 @@ DEPEND="${RDEPEND}
$(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}