summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 16:43:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 17:12:27 +0100
commit33e5c55efe86e07fc0c66e9bf051e8149432b825 (patch)
treed132a200dd5462b618e2e89c882d2abd232102a9 /dev-ros/roslaunch/roslaunch-1.13.4.ebuild
parentdev-ros/clear_costmap_recovery: bump costmap2d dep (diff)
downloadgentoo-33e5c55efe86e07fc0c66e9bf051e8149432b825.tar.gz
gentoo-33e5c55efe86e07fc0c66e9bf051e8149432b825.tar.bz2
gentoo-33e5c55efe86e07fc0c66e9bf051e8149432b825.zip
dev-ros/roslaunch: Remove old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/roslaunch/roslaunch-1.13.4.ebuild')
-rw-r--r--dev-ros/roslaunch/roslaunch-1.13.4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ros/roslaunch/roslaunch-1.13.4.ebuild b/dev-ros/roslaunch/roslaunch-1.13.4.ebuild
deleted file mode 100644
index be129d151484..000000000000
--- a/dev-ros/roslaunch/roslaunch-1.13.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
-
-inherit ros-catkin user
-
-DESCRIPTION="Tool for easily launching multiple ROS nodes"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/rosclean[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/rosparam[${PYTHON_USEDEP}]
- dev-ros/rosmaster[${PYTHON_USEDEP}]
- dev-ros/rosout
-"
-DEPEND="${RDEPEND}
- test? (
- dev-util/rosdep[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-ros/test_rosmaster
- )"
-PATCHES=( "${FILESDIR}/timeout.patch" )
-
-src_test() {
- rosdep update
- ros-catkin_src_test
-}
-
-src_install() {
- ros-catkin_src_install
-
- dodir /etc/ros
- sed -e "s/@PKG_VERSION@/${PV}/" "${FILESDIR}/roscore.xml.in" > "${ED}/etc/ros/roscore.xml" || die
-
- newinitd "${FILESDIR}/roscore.initd" roscore
- newconfd "${FILESDIR}/roscore.confd" roscore
-
- newinitd "${FILESDIR}/roslaunch.initd" roslaunch
- newconfd "${FILESDIR}/roslaunch.confd" roslaunch
-
- doenvd "${FILESDIR}/40roslaunch"
-
- # Needed by test_roslaunch
- insinto /usr/share/${PN}
- doins test/xml/noop.launch
-}
-
-pkg_preinst() {
- enewgroup ros
- enewuser ros -1 -1 /home/ros ros
-}