summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:25:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit3a7e9a3a90aac90d27cc5378ddf273c6ee0ac497 (patch)
tree6af458565aaa9b067c8d5a8614cc6e3e40ebd331 /dev-ros/roslib/roslib-1.12.5.ebuild
parentdev-ros/roslang: Bump to 1.12.5. (diff)
downloadgentoo-3a7e9a3a90aac90d27cc5378ddf273c6ee0ac497.tar.gz
gentoo-3a7e9a3a90aac90d27cc5378ddf273c6ee0ac497.tar.bz2
gentoo-3a7e9a3a90aac90d27cc5378ddf273c6ee0ac497.zip
dev-ros/roslib: Bump to 1.12.5.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/roslib/roslib-1.12.5.ebuild')
-rw-r--r--dev-ros/roslib/roslib-1.12.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roslib/roslib-1.12.5.ebuild b/dev-ros/roslib/roslib-1.12.5.ebuild
new file mode 100644
index 000000000000..5530a2dd15ad
--- /dev/null
+++ b/dev-ros/roslib/roslib-1.12.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Base dependencies and support libraries for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-ros/rospack
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"