summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-05 13:40:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-06 20:23:19 +0100
commit354faa34a12068a6e3029d39397c9c59c06b6946 (patch)
tree46d69eaad78b465cc3062c7b2db287f8a2cddd11 /dev-ros/rosmake/rosmake-1.14.3.ebuild
parentdev-ros/roscreate: Bump to 1.14.3. (diff)
downloadgentoo-354faa34a12068a6e3029d39397c9c59c06b6946.tar.gz
gentoo-354faa34a12068a6e3029d39397c9c59c06b6946.tar.bz2
gentoo-354faa34a12068a6e3029d39397c9c59c06b6946.zip
dev-ros/rosmake: Bump to 1.14.3.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.14.3.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.14.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.14.3.ebuild b/dev-ros/rosmake/rosmake-1.14.3.ebuild
new file mode 100644
index 000000000000..bfa505412da9
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.14.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"