summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:29:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:54 +0200
commitbe628e6cad0466bf3a3bfe1e93cbc1432d3c3c03 (patch)
tree47cb7ad308dcc8391cd49794019b333d225afc0f /dev-ros/rosmaster/rosmaster-1.15.8.ebuild
parentdev-ros/roslaunch: Bump to 1.15.8. (diff)
downloadgentoo-be628e6cad0466bf3a3bfe1e93cbc1432d3c3c03.tar.gz
gentoo-be628e6cad0466bf3a3bfe1e93cbc1432d3c3c03.tar.bz2
gentoo-be628e6cad0466bf3a3bfe1e93cbc1432d3c3c03.zip
dev-ros/rosmaster: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosmaster/rosmaster-1.15.8.ebuild')
-rw-r--r--dev-ros/rosmaster/rosmaster-1.15.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosmaster/rosmaster-1.15.8.ebuild b/dev-ros/rosmaster/rosmaster-1.15.8.ebuild
new file mode 100644
index 000000000000..82438464c6ff
--- /dev/null
+++ b/dev-ros/rosmaster/rosmaster-1.15.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS Master implementation"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/defusedxml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )"