summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-04 11:31:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-04 12:05:36 +0100
commit67bb348fb7b30779e87028b8f1e190cd2e28baad (patch)
treefdbd5328b3c6afa770a95cc93dabbdf7d8631402 /dev-ros/rosmsg/rosmsg-1.13.4.ebuild
parentdev-ros/rosmaster: Bump to 1.13.4. (diff)
downloadgentoo-67bb348fb7b30779e87028b8f1e190cd2e28baad.tar.gz
gentoo-67bb348fb7b30779e87028b8f1e190cd2e28baad.tar.bz2
gentoo-67bb348fb7b30779e87028b8f1e190cd2e28baad.zip
dev-ros/rosmsg: Bump to 1.13.4.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-1.13.4.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-1.13.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/rosmsg-1.13.4.ebuild b/dev-ros/rosmsg/rosmsg-1.13.4.ebuild
new file mode 100644
index 000000000000..5298eb858e66
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.13.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"