summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:11:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:46 +0200
commit6f2a78d60c6986d3bd933cff78eb31ca6b5c7577 (patch)
tree1efb9ee3d5cf1305e09d6497520e0236e76b99e8 /dev-ros/rosnode/rosnode-1.13.1.ebuild
parentdev-ros/rosmsg: Bump to 1.13.1. (diff)
downloadgentoo-6f2a78d60c6986d3bd933cff78eb31ca6b5c7577.tar.gz
gentoo-6f2a78d60c6986d3bd933cff78eb31ca6b5c7577.tar.bz2
gentoo-6f2a78d60c6986d3bd933cff78eb31ca6b5c7577.zip
dev-ros/rosnode: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rosnode/rosnode-1.13.1.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-1.13.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosnode/rosnode-1.13.1.ebuild b/dev-ros/rosnode/rosnode-1.13.1.ebuild
new file mode 100644
index 000000000000..b9104d989756
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.13.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"