summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-05 11:24:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-05 11:24:03 +0200
commitee4adc2ab20cc889e355deb07c26281adc6e344d (patch)
treeef63bb0fa985c1e1fa9eb622feab2a32d83d5678 /dev-ros/rospack/rospack-2.3.1.ebuild
parentdev-ros/rospack: remove old (diff)
downloadgentoo-ee4adc2ab20cc889e355deb07c26281adc6e344d.tar.gz
gentoo-ee4adc2ab20cc889e355deb07c26281adc6e344d.tar.bz2
gentoo-ee4adc2ab20cc889e355deb07c26281adc6e344d.zip
dev-ros/rospack: bump to 2.3.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/rospack/rospack-2.3.1.ebuild')
-rw-r--r--dev-ros/rospack/rospack-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/rospack/rospack-2.3.1.ebuild b/dev-ros/rospack/rospack-2.3.1.ebuild
new file mode 100644
index 000000000000..e1ae3b91b4a7
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=
+ dev-libs/tinyxml
+ "
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"