summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-03 11:37:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-03 13:10:52 +0200
commit7d5cdf0ec9ad69ff1ddca4c4e677014ca2342ef7 (patch)
treec85720c8b4378b92123ef7c7597aabfa76c13898 /dev-ros/rosparam/rosparam-1.12.5.ebuild
parentdev-ros/rosout: Bump to 1.12.5. (diff)
downloadgentoo-7d5cdf0ec9ad69ff1ddca4c4e677014ca2342ef7.tar.gz
gentoo-7d5cdf0ec9ad69ff1ddca4c4e677014ca2342ef7.tar.bz2
gentoo-7d5cdf0ec9ad69ff1ddca4c4e677014ca2342ef7.zip
dev-ros/rosparam: Bump to 1.12.5.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rosparam/rosparam-1.12.5.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-1.12.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-1.12.5.ebuild b/dev-ros/rosparam/rosparam-1.12.5.ebuild
new file mode 100644
index 000000000000..cd0ef7f7f262
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-1.12.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"