summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:07:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:23 +0200
commit511cc62e3872761efc23260d3a9b32de8dc13069 (patch)
treeb6ea304db5212ed79fa69be5103d9f92a729cef1 /dev-ros/rosparam/rosparam-9999.ebuild
parentdev-ros/roslz4: Initial import. Ebuild by me. (diff)
downloadgentoo-511cc62e3872761efc23260d3a9b32de8dc13069.tar.gz
gentoo-511cc62e3872761efc23260d3a9b32de8dc13069.tar.bz2
gentoo-511cc62e3872761efc23260d3a9b32de8dc13069.zip
dev-ros/rosparam: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosparam/rosparam-9999.ebuild')
-rw-r--r--dev-ros/rosparam/rosparam-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosparam/rosparam-9999.ebuild b/dev-ros/rosparam/rosparam-9999.ebuild
new file mode 100644
index 000000000000..608ff1c36d31
--- /dev/null
+++ b/dev-ros/rosparam/rosparam-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for getting and setting ROS Parameters on the parameter server"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"