summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-06 12:46:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-06 13:12:51 +0200
commit665cc7bd2c8859f0d851a8b4c772e7121f94afca (patch)
tree9efafe5dd62c91e62ac5f9967fd1e1452e5e7892 /dev-ros/rospy/rospy-1.12.2.ebuild
parentdev-ros/roscpp: Bump to 1.12.2. (diff)
downloadgentoo-665cc7bd2c8859f0d851a8b4c772e7121f94afca.tar.gz
gentoo-665cc7bd2c8859f0d851a8b4c772e7121f94afca.tar.bz2
gentoo-665cc7bd2c8859f0d851a8b4c772e7121f94afca.zip
dev-ros/rospy: Bump to 1.12.2.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/rospy/rospy-1.12.2.ebuild')
-rw-r--r--dev-ros/rospy/rospy-1.12.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rospy/rospy-1.12.2.ebuild b/dev-ros/rospy/rospy-1.12.2.ebuild
new file mode 100644
index 000000000000..5dd4e45e35f2
--- /dev/null
+++ b/dev-ros/rospy/rospy-1.12.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ # Other tests need these nodes
+ exeinto /usr/share/${PN}
+ doexe test_nodes/*
+}