summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:56:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:22 +0200
commit041ef269e1f57ec812c115d97571cbe8d511cd96 (patch)
treef523f2239a3686b1afd1ca43d9841989cd420755 /dev-ros/rospy/rospy-9999.ebuild
parentdev-ros/rosgraph: Initial import. Ebuild by me. (diff)
downloadgentoo-041ef269e1f57ec812c115d97571cbe8d511cd96.tar.gz
gentoo-041ef269e1f57ec812c115d97571cbe8d511cd96.tar.bz2
gentoo-041ef269e1f57ec812c115d97571cbe8d511cd96.zip
dev-ros/rospy: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rospy/rospy-9999.ebuild')
-rw-r--r--dev-ros/rospy/rospy-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rospy/rospy-9999.ebuild b/dev-ros/rospy/rospy-9999.ebuild
new file mode 100644
index 000000000000..1d2ec33e68e5
--- /dev/null
+++ b/dev-ros/rospy/rospy-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"