summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:46:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:46:54 +0200
commit69ff06953ad348d23ebc57acfc73286f1c1c8d0b (patch)
treeff7265fbe0db27aa4c14a639d0d68e42814d3d75 /dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
parentdev-ros/roscpp_tutorials: Initial import. Ebuild by me. (diff)
downloadgentoo-69ff06953ad348d23ebc57acfc73286f1c1c8d0b.tar.gz
gentoo-69ff06953ad348d23ebc57acfc73286f1c1c8d0b.tar.bz2
gentoo-69ff06953ad348d23ebc57acfc73286f1c1c8d0b.zip
dev-ros/rospy_tutorials: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild')
-rw-r--r--dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild b/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
new file mode 100644
index 000000000000..f1332470fdd1
--- /dev/null
+++ b/dev-ros/rospy_tutorials/rospy_tutorials-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step, including using messages, servers, parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"